Viewing 10 posts - 41 through 50 (of 894 total)
  • Author
    Posts
  • #983
    João Pereira
    Keymaster

    thanks for the super fast update as soon as it’s updated on the playstore i will try it

    As I said in my last edit the bug you reported was not fixed in last update. It is now and will be pushed later today for todays beta update.

    Hello John, I tried it yesterday again but still there is no movement of the degrees heading. It stands and it is not changing. Regards

    I hope you understood it only works when you are actually using it on a car or motorcycle, you need to be moving at more than 3Km/h.
    If it does not work thats a really bad sign, fortunately you can now debug the GPS updates, in the HOME screen click on the code wheel in the center and add to the left or right panel a widget called “GPS DEBUG” ride looking at it, it will tell you if the location updates are being accepted or ignored and why is it being ignored. I will make a tutorial about this soon.

    DMD2 Project Manager & Lead Developer
    Buy Me a Coffee

    #986
    João Pereira
    Keymaster

    Controller: 2.76 Manager: 5.1 DMD2: 2.81 Noticed a few issues this morning

    1. When I’m on the home screen, the controller seems to act unpredictably. Used to be that left and right would switch pages, now it seems to either switch the left custom panel, or control the map if that’s open.
    2. Speed was registering at about 50% more than I was actually doing. I’m set to imperial, and doing 60mph DMD2 registered 90 mph. It displays mph as the unit.
    3. The trip meter doesn’t seem to advance. The time increases, but it doesn’t register any distance. I’ve tried resetting. This also affects the road book which doesn’t move the meters therein either.
    4. If the custom home tile is set to the map, it becomes really difficult to swipe with a finger to the next tile: the map is panned instead. I’d suggest just locking it for gestures, but tapping it takes you to the map?
    5. Album art not appearing on the media custom tile.
    6. Is it possible to use the name of the app for the external widget instead of ‘External Widget’? I’m using Windy, and it would be nice to use either ‘Windy’ (app name) or ‘Windy Radar Widget’ (widget name).
    7. Tapping ‘Advanced’ for a track in the track manager doesn’t do anything

    1. Controllers now work in a different way, full manual will be added in the website, you can have a glimpse about what changed in this boring video:

    2. Speed was not being converted to Miles, sorry, fixed for todays update.
    3. Trip should move, if not it is not taking your location updates. Please add the GPS Debug widget to any of the panels, like this:

    The square that says “IGNORED” means that app is ignoring your location update dues to bad precision, if it is green then it means it accepted it.
    Check it and share a picture (always wile driving and never stopped or walking).

    The widget swipe will be changed, it will only be accepted if you swipe in the title area.

    If album artwork does not show it means you probably have an old Android version since the only limitation is that, older Android versions do not support it.

    Will try to improve the widget name feature, it currently works only if you cycle them once or exit and reopen the app.

    GPX Manager Advanced features are in development, will soon be available.

    DMD2 Project Manager & Lead Developer
    Buy Me a Coffee

    #987
    marius.mihasan
    Participant

    Can you tell me the exact dongle model and where I can buy one? Everyone seems to be reporting the OBDLINK is working perfectly, but I would really like to make sure other dongles work just as fine. I will get one and find out whats causing this really fast.

    Hm, ist a cheap Chinese dongle. I bought it from here, but it is a Romanian store. Looks identical to some from Alliexpress.

    I managed to somehow make it display the correct RPM. I have to follow these steps:

    -all slots for sensors are set to fuel level. Only rpm is displayed. Don’t know if it makes a difference, but did not try another way.

    -plug the dongle and start the engine;

    -DMD2 starts and in a few seconds connects to the dongle –  the Bluetooth icon in DMD2 turns blue and a fixed value for rpm is shown, always the same value, something like 4xxx. The dongle lights green and the green lights twinkle, as it would communicate/exchange data.

    – with the engine running I quickly unplug the ODB dongle,  the Bluetooth icon in DMD2 turns red, and then plug ODB dongle back in again. The Bluetooth icon in DMD2 turns blue for a few seconds, then red again, then blue, and stays blue. Now the rpm value is displayed properly and responds to the gas pedal.

    -if I exit DMD2 or restart the android device, I have to redo the whole procedure.

    I do remember now that also with the old version, the auto-connection to the OBDII dongle does not always work. I was keeping it off, and manually connecting to the dongle (with the old version – engine started, DMD started, Bluetooth icon red, then initiate the connection manually).

    It might be hence an issue with the autoconnection, so maybe is a good idea to have the same options as in the old version (option to manually initiate the connection, option to turn off auto-connect).

    Thanks for all the great work.

    #988
    João Pereira
    Keymaster

    Can you tell me the exact dongle model and where I can buy one? Everyone seems to be reporting the OBDLINK is working perfectly, but I would really like to make sure other dongles work just as fine. I will get one and find out whats causing this really fast.

    Hm, ist a cheap Chinese dongle. I bought it from here, but it is a Romanian store. Looks identical to some from Alliexpress. I managed to somehow make it display the correct RPM. I have to follow these steps: -all slots for sensors are set to fuel level. Only rpm is displayed. Don’t know if it makes a difference, but did not try another way. -plug the dongle and start the engine; -DMD2 starts and in a few seconds connects to the dongle – the Bluetooth icon in DMD2 turns blue and a fixed value for rpm is shown, always the same value, something like 4xxx. The dongle lights green and the green lights twinkle, as it would communicate/exchange data. – with the engine running I quickly unplug the ODB dongle, the Bluetooth icon in DMD2 turns red, and then plug ODB dongle back in again. The Bluetooth icon in DMD2 turns blue for a few seconds, then red again, then blue, and stays blue. Now the rpm value is displayed properly and responds to the gas pedal. -if I exit DMD2 or restart the android device, I have to redo the whole procedure. I do remember now that also with the old version, the auto-connection to the OBDII dongle does not always work. I was keeping it off, and manually connecting to the dongle (with the old version – engine started, DMD started, Bluetooth icon red, then initiate the connection manually). It might be hence an issue with the autoconnection, so maybe is a good idea to have the same options as in the old version (option to manually initiate the connection, option to turn off auto-connect). Thanks for all the great work.

    Version 2.82 (03/02/2023)
    – Made some changes in the OBD Service to attempt to keep some slower dongles to fail the autoconnect
    – REALLY fixed the issue in map layer manager where it would load different maps than the once selected on the list
    – Fixed a bug where Imperial Units were ignored
    – Fixed Hillshading API Key issue

    DMD2 Project Manager & Lead Developer
    Buy Me a Coffee

    #1031
    Tomppa65
    Participant

    Hello John,

     

    I checked your advice. Its on “Ignored”.

     

    Regards

    #1032
    João Pereira
    Keymaster

    Hello John, I checked your advice. Its on “Ignored”. Regards

    Ignored but why? Which values are in red? Bearing ACC / Altitude ACC / Speed Acc / Motion? When one of those is red it means thats the value/values causing the updates to be ignored. Which one is it?
    Lets just hope thats not simply your device GPS quality…

    DMD2 Project Manager & Lead Developer
    Buy Me a Coffee

    #1035
    Tomppa65
    Participant

    Hello John, bearing ACC is red.

    Regards

    Thomas

    #1050
    Tomppa65
    Participant

    One more thing: Weather widgets are also not working. Windy not and My Radar also not. It says no data available. App as such is working flawless. Otherwise a great app!!! Could replace Garmin in future.

    Regards

    #1061
    rak
    Participant

    Replacing Garmin … what I miss is Navigation not along a GPX but to an ad be address … I did not find that. Am I missing something?

    #1065
    linssen
    Participant

    1. Controllers now work in a different way, full manual will be added in the website, you can have a glimpse about what changed in this boring video:

    Even with that description it’s not working that way for me. I suspect it’s because I’ve added the map as a panel on the left side. Even before you hit ‘⏎’ the map scrolls.

    If you phsically tap the screen to move to a new panel, then use the controller I think it is still panning the map. After a while the correct ←/→ to change left, and ↑/↓ to change right work. Not reliably though. Help with repro steps would be appreciated – I know these aren’t that helpful.

    3. Trip should move, if not it is not taking your location updates. Please add the GPS Debug widget to any of the panels, like this:

    Compass seems good, map updates well, accuracy <1 most of the time, still no trip; not recording. Screenshot from mid-ride

    If album artwork does not show it means you probably have an old Android version since the only limitation is that, older Android versions do not support it.

    It’s the Carpe Iter CI_pad_v4 running Android 9.

Viewing 10 posts - 41 through 50 (of 894 total)
  • You must be logged in to reply to this topic.