#895
marius.mihasan
Participant

I have been using since some time now a generic ELM327  dongle (which looks identical to this one) to connect DMD2 with my car’s ODB system. The setup used to work on all my devices: a Pixel 4, a Blackview BV9900 phone, and the generic android headunit in my car. DMD2 was connecting to the dongle and getting rpm, throttle position, voltage, and other values.

After installing the beta, the OBD part in DMD2 appears to be stuck and always reporting the same values on all devices – as shown in the pics. Unplugging and replugging the dongle did not help, restarting the android devices did not help. Selecting manually various ISO_15765_4_can…. protocols did not help. As I remember, for some protocols DMD was cycling between connected and disconnected and no data was displayed. Dont remember which one, but if it is important and do some tests and be more careful. The static data from the pics is displayed when the protocol is set to auto and is consistent throughout the day – several car engine starts, headunit restarts and dongle unplugs and replugs.

The dongle still works using other ODB apps. I think that is a problem in how the beta reads the data from the dongle. I would be happy to provide feedback that would help solve the issue.

dmd2 in my car DMD2 on my Pixel 4 phone Protocol used by other apps that work with my dongle

  • This reply was modified 1 year, 3 months ago by marius.mihasan. Reason: added pics
  • This reply was modified 9 months, 1 week ago by João Pereira.